App Unavailability - Minor
Incident Report for Documo
Resolved
This incident has been resolved.
Posted Jun 26, 2020 - 08:15 PDT
Update
We have found and resolved the issue
Posted Jun 26, 2020 - 08:15 PDT
Investigating
We are currently investigating this issue.
Posted Jun 26, 2020 - 06:59 PDT
This incident affected: Web Portal, API, Numbers Porting, and Numbers Provision.