Email to Fax errors
Incident Report for Documo
Resolved
This incident has been resolved and the team will continue to monitor.
Posted Aug 02, 2022 - 09:04 PDT
Update
We are continuing to investigate this issue.
Posted Aug 02, 2022 - 08:38 PDT
Investigating
We are currently investigating an issue prohibiting users from using our domain (send.mfax.io) for email to fax.
Posted Aug 02, 2022 - 08:15 PDT
This incident affected: Fax Services.