Fax syncing delay
Incident Report for Documo
Resolved
This incident has been resolved.
Posted Sep 14, 2020 - 11:35 PDT
Monitoring
This is affecting inbound and outbound faxes. A resolution to fax syncing has been identified and implemented. We are currently monitoring the system.
Posted Sep 14, 2020 - 09:16 PDT
This incident affected: Fax Services.