Outbound Delay

Incident Report for Documo

Resolved

This incident has been resolved.
Posted May 02, 2025 - 05:55 PDT

Monitoring

We have implemented a number of routing and retry handling adjustments to mitigate excessive busy signals and otherwise underperforming telecom segments that lead to longer than expected processing times on outbound traffic for some customers & numbers.

All traffic is now performing at expected levels, and any remaining outbound faxes in processing state should clear over the next few hours.
Posted May 01, 2025 - 19:57 PDT

Identified

Higher than normal busy responses on telecom networks in some regions are causing isolated outbound processing delays. We are working with our telecom partners to resolve. More updates to follow.
Posted May 01, 2025 - 14:01 PDT

Investigating

We are currently investigating an issue where a subset of customers are experiencing outbound transmission delays. More updates to come.
Posted May 01, 2025 - 12:57 PDT
This incident affected: Fax Services.