Issues with History page

Incident Report for Documo

Resolved

This incident has been resolved.
Posted Jun 18, 2024 - 15:12 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 18, 2024 - 13:31 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 18, 2024 - 13:25 PDT

Investigating

We are currently investigating an issue with user's 'History' page within the portal. Updates to follow.
Posted Jun 18, 2024 - 13:01 PDT
This incident affected: Web Portal.