View/Download fax in web portal

Incident Report for Documo

Postmortem

Viewing or Downloading faxes in the web portal was causing an unintentional 429 error indicating the user had made too many requests to the underlying portal API in a short period of time.

This was an incorrect error caused by an improper aggregate calculation tracking API usage metrics for rate throttling.

Posted Jun 10, 2024 - 09:18 PDT

Resolved

This incident has been resolved.
Posted Jun 03, 2024 - 07:59 PDT

Update

We are continuing to monitor for any further issues.
Posted May 31, 2024 - 07:23 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 31, 2024 - 07:23 PDT

Investigating

We are currently investigating an issue where an error occurs when viewing or downloading a fax in the web portal. More updates to come.
Posted May 31, 2024 - 06:20 PDT
This incident affected: Web Portal.