Portal Disruptions

Incident Report for Documo

Resolved

This incident has been resolved.
Posted Jun 15, 2026 - 09:41 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 15, 2026 - 08:23 PDT

Update

We are continuing to investigate this issue.
Posted Jun 15, 2026 - 08:07 PDT

Investigating

We are currently investigating an issue causing disruptions with our API, portal, and fax services. Our team is working diligently to resolve. Updates to follow.
Posted Jun 15, 2026 - 07:51 PDT
This incident affected: API, Fax Services, and Web Portal.