Missing Email Notifications
Incident Report for Documo
Resolved
This incident has been resolved.
Posted Aug 30, 2023 - 07:28 PDT
Update
We are continuing to monitor the results of the fix.
Posted Aug 29, 2023 - 13:50 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 29, 2023 - 10:54 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 29, 2023 - 10:18 PDT
Investigating
Our team is currently investigating an issue that a subset of users are not receiving email notifications for sent/received faxes.

Updates to follow.
Posted Aug 29, 2023 - 07:19 PDT
This incident affected: Email Notifications.