Multiple Notifications for Email to Fax
Incident Report for Documo
Resolved
This incident has been resolved.
Posted Jun 08, 2023 - 06:02 PDT
Monitoring
A fix has been implemented and we are monitoring the results. Updates to follow.
Posted Jun 07, 2023 - 11:23 PDT
Investigating
We are currently investigating an issue causing a subset of our customers to receive multiple email to fax notifications when sending via email to fax. Updates to follow.
Posted Jun 07, 2023 - 11:02 PDT
This incident affected: Email Notifications.