Outbound Delays

Incident Report for Documo

Resolved

This incident has been resolved.
Posted Jan 07, 2025 - 17:17 PST

Monitoring

We have implemented a fix for the current outbound delays and are monitoring the results. More updates to follow.
Posted Jan 07, 2025 - 12:39 PST
This incident affected: Fax Services.