Server Unavailability
Incident Report for Documo
Resolved
This incident has been resolved.
Posted Feb 10, 2021 - 01:48 PST
Investigating
We are currently investigating this issue.
Posted Feb 10, 2021 - 01:25 PST
This incident affected: Web Portal, API, Email Notifications, Fax Services, FaxBridges, Numbers Porting, and Numbers Provision.