FaxBridge Disruptions
Incident Report for Documo
Resolved
This incident has been resolved.
Posted Jul 19, 2024 - 13:21 PDT
Monitoring
With the known Crowdstrike outage, FaxBridges have been impacted. As of 10:35 am PST, our vendor has acknowledged patches to the server. We are continuing to monitor.
Posted Jul 19, 2024 - 12:08 PDT
This incident affected: Fax ATA Devices.