Portal Down
Incident Report for Documo
Resolved
This incident has been resolved
Posted Apr 03, 2023 - 09:41 PDT
Identified
The issue has been identified and the team is working to resolve. Updates to follow.
Posted Apr 03, 2023 - 08:52 PDT
Update
We are continuing to investigate this issue. Updates to follow.
Posted Apr 03, 2023 - 08:38 PDT
Investigating
We are currently investigating an issue causing users to receive a 503 Service Temporarily Unavailable when trying to access the portal. Updates to follow.
Posted Apr 03, 2023 - 08:15 PDT
This incident affected: API, Fax Services, and Web Portal.