Portal lag
Incident Report for Documo
Resolved
This incident has been resolved.
Posted May 15, 2023 - 05:58 PDT
Identified
We have identified an issue causing a subset of users to experience lag within the portal. Our engineers are working on a resolution and we will update as soon as we have more information.
Posted May 12, 2023 - 12:34 PDT
This incident affected: Web Portal.