Errors when accessing faxes

Incident Report for Documo

Resolved

This incident has been resolved.
Posted Apr 07, 2025 - 10:51 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 07, 2025 - 09:47 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 07, 2025 - 07:13 PDT

Investigating

We are currently investigating an issue causing errors within the portal when attempting to view, print, or download faxes. Updates to follow.
Posted Apr 07, 2025 - 06:27 PDT
This incident affected: Web Portal.