UUID Error When Opening Faxes

Incident Report for Documo

Resolved

This incident has been resolved.
Posted Jun 03, 2026 - 08:09 PDT

Monitoring

A fix has been implemented and we are monitoring the results. Updates to follow.
Posted Jun 03, 2026 - 07:27 PDT

Investigating

We are currently investigating an issue causing UUID errors when attempting to open faxes within the web portal. Updates to follow.
Posted Jun 03, 2026 - 06:26 PDT
This incident affected: Web Portal.