Outbound delays

Incident Report for Documo

Resolved

The backlogged faxes have been processed. This incident is now resolved.
Posted Feb 26, 2025 - 16:18 PST

Monitoring

A fix has been implemented and we are monitoring the results. Backlogged faxes will take time to work through. All net new faxes are going through at expected times. More updates to follow.
Posted Feb 26, 2025 - 14:23 PST

Investigating

We are currently investigating an issue causing outbound fax delays. Updates to follow.
Posted Feb 26, 2025 - 13:21 PST
This incident affected: Fax Services.