Email Suppression Notifications

Incident Report for Documo

Resolved

This incident has been resolved.
Posted Jun 10, 2026 - 10:27 PDT

Identified

The issue has been identified and a fix is being implemented. Updates to follow.
Posted Jun 10, 2026 - 09:18 PDT

Investigating

We are currently investigating an issue causing a subset of users to receive large amounts of email suppression notifications. Updates to follow.
Posted Jun 10, 2026 - 09:16 PDT
This incident affected: Email Notifications.