Increased latency to our numbers provider
Incident Report for Documo
Resolved
This incident has been resolved.
Posted Feb 10, 2020 - 07:07 PST
Investigating
We have identified an increased latency in response times to our numbers provider.
Users may see a delay in port creation and numbers provision.
Posted Feb 10, 2020 - 06:14 PST
This incident affected: Numbers Porting and Numbers Provision.