Outbound Faxing Delays
Incident Report for Documo
Resolved
This incident has been resolved.
Posted Nov 28, 2023 - 10:58 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 28, 2023 - 10:26 PST
Investigating
Our team has identified an issue causing outbound faxes to send at a delayed rate. Inbound faxing is working as expected. The team is working diligently to resolve. Updates to follow.
Posted Nov 28, 2023 - 09:57 PST
This incident affected: Fax Services.