Inbound faxes not syncing to user's history
Incident Report for Documo
Resolved
This incident has been resolved.
Posted Jan 15, 2025 - 08:56 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 15, 2025 - 07:02 PST
Investigating
We are currently investigating an issue where inbound faxes are not appearing on a user's history page. Updates to follow.
Posted Jan 15, 2025 - 07:00 PST
This incident affected: Fax Services.