IDP Document Processing Delays

Incident Report for Documo

Resolved

This incident has been resolved.
Posted Jul 21, 2026 - 16:09 PDT

Monitoring

A fix has been implemented and we are monitoring the results. This incident created a backlog of documents that need to be processed and we expect the backlog to be cleared over the next two hours.
Posted Jul 21, 2026 - 15:31 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 21, 2026 - 14:05 PDT

Investigating

We are currently investigating an issue causing a longer than usual wait time for documents to be processed using our IDP product. More updates to follow.
Posted Jul 21, 2026 - 13:54 PDT
This incident affected: Intelligent Document Processing.