Inbound and Outbound Faxing Delays
Incident Report for Documo
Resolved
This incident has been resolved.
Posted Sep 18, 2023 - 10:53 PDT
Monitoring
A fix has been implemented and we are monitoring the results. More updates to follow.
Posted Sep 18, 2023 - 10:05 PDT
Update
We are continuing to investigate this issue.
Posted Sep 18, 2023 - 08:28 PDT
Investigating
We are currently investigating an issue that is leading to a slow sync of inbound faxes and outbound fax status update delays. More updates to follow.
Posted Sep 18, 2023 - 07:30 PDT
This incident affected: Fax Services.