Slow outbound fax processing

Incident Report for Documo

Resolved

This incident has been resolved.
Posted Oct 12, 2023 - 08:56 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 12, 2023 - 08:23 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 12, 2023 - 08:02 PDT

Investigating

We are currently investigating this issue.
Posted Oct 12, 2023 - 07:46 PDT
This incident affected: Fax Services.