Users experiencing latency while signing in

Incident Report for Documo

Resolved

This incident has been resolved.
Posted Feb 25, 2022 - 12:31 PST

Investigating

We are currently investigating an issue where users are experiencing extended login times. Updates to follow.
Posted Feb 25, 2022 - 11:57 PST
This incident affected: Web Portal.