Faxes not appearing in history
Incident Report for Documo
Resolved
This incident has been resolved.
Posted Mar 21, 2023 - 09:56 PDT
Monitoring
A fix has been implemented and we are now monitoring the results.
Posted Mar 21, 2023 - 08:06 PDT
Update
A fix is still being implemented by our engineers. Updates to follow.
Posted Mar 21, 2023 - 07:54 PDT
Identified
The issue has been identified and a fix is being implemented. Updates to follow.
Posted Mar 21, 2023 - 06:54 PDT
Investigating
We are currently investigating an issue causing faxes to not appear in history without filtering. Updates to follow.
Posted Mar 21, 2023 - 06:50 PDT
This incident affected: Fax Services.