Outbound fax delays
Incident Report for Documo
Resolved
This incident has been resolved.
Posted Aug 31, 2023 - 06:26 PDT
Monitoring
A fix has been implemented and we are monitoring fax traffic overnight to ensure it is working properly. More updates will be provided as they become available.
Posted Aug 30, 2023 - 16:58 PDT
Update
We are continuing to investigate this issue.
Posted Aug 30, 2023 - 11:53 PDT
Investigating
We are investigating an issue leading to outbound fax delays. More updates to follow.
Posted Aug 30, 2023 - 09:00 PDT
This incident affected: Fax Services.