Delay on outbound faxing
Incident Report for Documo
Resolved
This incident has been resolved.
Posted Aug 12, 2022 - 06:22 PDT
Update
We are continuing to investigate this issue.
Posted Aug 11, 2022 - 17:14 PDT
Update
We are continuing to investigate this issue.
Posted Aug 11, 2022 - 14:30 PDT
Investigating
Our team is currently investigating an issue that is causing outbound delays on faxes. Inbound is working as expected.
Posted Aug 11, 2022 - 14:09 PDT
This incident affected: Fax Services.