Delay on faxing
Incident Report for Documo
Resolved
This incident has been resolved.
Posted May 13, 2022 - 11:38 PDT
Monitoring
A fix has been implemented and the team will continue to monitor results. Please reach out to support with any questions.
Posted May 13, 2022 - 10:28 PDT
Identified
Our team has identified the issue and is working to resolve. We will continue to provide updates as we have them.
Posted May 13, 2022 - 09:08 PDT
Investigating
Our team is currently investigating an issue that is causing delays on inbound faxing to a subset of our customers. We are working diligently to identify and resolve. Updates to follow.
Posted May 13, 2022 - 08:53 PDT
This incident affected: Fax Services.