Portal affected
Incident Report for Documo
Resolved
This incident has been resolved.
Posted Apr 25, 2022 - 16:23 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 25, 2022 - 15:50 PDT
Investigating
We are currently aware of an issue with accessing the application for a subset of customers. You may experience an 'mFax subscription required' error. The team is working diligently to identify the problem and provide a resolution. Updates to follow.
Posted Apr 25, 2022 - 15:16 PDT
This incident affected: Web Portal, API, and Fax Services.